Computer & Technik
Programmieren
» Home » [Computer & Technik] Excel & Co. » Programmieren




» Summe pro Bedingung
» Summe zweier Bedingungen
» Summe pro Monat
» Summen aus Monat
Chip

Summe pro Bedingung

Gegeben sind mehrere Bedingungen mit entsprechend dazugehöriger Menge.

Es soll zu jeder Bedingung die Gesamtmenge errechnet werden.

Entsprechend diesem Beispiel im Feld F3 folgendes eingeben:
=SUMMEWENN(C:C;E3;B:B)

Wird der Bereich E3 bis E9 nicht gesperrt (beim Schutz des Blattes), so ist diese Liste jederzeit erweiterbar.

Möchte man nur wissen, wie oft eine Bedingung vorkommt, kann man folgende Zeile verwenden:
=ZäHLENWENN(C:C;E3)

SumIf
Chip

Summe zweier Bedingungen


Gegeben sind jeweils zwei Bedingungen.
Es soll gezählt werden, wie oft Bedingung 1 und Bedingung 2 gleichzeitig erfüllt sind.

In den gelben Feldern B1 und C1 sollen die gesuchten Werte eingegeben werden (Felder nicht sperren).

In diesem Beispiel im Feld F13 folgendes eingeben:
=SUMMENPRODUKT((B2:B65000=B1)*(C2:C65000=C1))

Nur zur Info: Im Feld D1 ist eine Kombination dieser drei Felder zu sehen. Die Formel sieht dann so aus:
="<< B:"&ZäHLENWENN(B:B;B1)-1&" // C:"&ZäHLENWENN(C:C;C1)-1&" // BC:"&SUMMENPRODUKT((B2:B65000=B1)*(C2:C65000=C1))

Die Felder F9 und F11 geben nur aus wie oft eine Bedingung erfüllt ist. In diesem Fall kann man die Formel
=ZäHLENWENN(B:B;B1)-1
verwenden.
Die -1 ist wichtig, da wir sonst das Feld B1 oder C1 mitzählen würden.

Oder eine andere Variante wäre:
=ZäHLENWENN(B3:B65000;B1)

Product
Chip

Summe pro Monat


Gegeben ist eine Spalte für das Datum und eine Spalte für Mengenangaben.
Es soll die Menge für jeden Monat berechnet werden.

In diesem Beispiel im Feld F5 folgendes eingeben:
=SUMME(WENN(MONAT($A$3:$A$65000)=1;$B$3:$B65000))

die Zeile mit Strg+Shift+Enter abschliessen. Die Formel wird in { } eingebunden und als Makro definiert. Nur so funktioniert die Formel dann auch richtig!
In der nächsten Zeile wird die 1 gegen 2 ersetzt (Februar), u.s.w..

Feld F1 hat hier noch keine Bedeutung. :-)



SumMonth
Chip

Summen aus Monat


Gegeben sind die Spalten Datum, Menge, Bedingung.

Wie im ersten Beispiel » Summe pro Bedingung haben wir die Gesamtsumme der Bedingungen.
Wir möchten allerdings die einzelnen Summen auf einen Monat beschränken.

Das Feld G1 dient zur Eingabe des Monats (Januar=1, Februar=2,...)

Ins Feld G4 kommt in unserem Beispiel die Formel (in eine Zeile):
=SUMME((MONAT(A3:A65000)=G1) * (C3:C65000=E4) * WENN(ISTZAHL(B3:B65000);B3:B65000;0))

In unserem Beispiel sehen wir, dass wir im Jahr 749 äpfel hatten, aber im Januar nur 426.
ändern wir den Eintrag in G1 auf 2 (Februar), so sehen wir die Menge an äpfeln, Birnen, usw. im Februar.

die Zeile mit Strg+Shift+Enter abschliessen. Die Formel wird in { } eingebunden und als Makro definiert. Nur so funktioniert die Formel dann auch richtig!

Bei dieser Berechnung kann es je nach Leistung des Computers zu Verzögerungen kommen.
SummMonth2